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• Copyright: © 2011 Miranda Technologies. All rights reserved. 

• No part of this manual may be reproduced in any form by photocopy, microfilm, xerography or 
any other means, or incorporated into any information retrieval system, electronic or mechani-
cal, without the written permission of Miranda Technologies, Inc. 

• The information contained in this manual is subject to change without notice or obligation.

• All title and copyrights as well as trade secret, patent and other proprietary rights in and to the 
Software Product (including but not limited to any images, photographs, animations, video, 
audio, music, test, and “applets” incorporated into the Software Product), the accompanying 
printed materials, and any copies of the Software Product, are owned by Miranda Technologies, 
Inc. The Software Product is protected by copyright laws and international treaty provisions. 
Customer shall not copy the printed materials accompanying the software product.

Notice
The software contains proprietary information of Miranda Technologies, Inc. It is provided under a 
license agreement containing restrictions on use and disclosure and is also protected by copyright 
law. Reverse engineering of the software is prohibited.

Due to continued product development, the accuracy of the information in this document may 
change without notice. The information and intellectual property contained herein is confidential 
between Miranda and the client and remains the exclusive property of Miranda. If you find any 
problems in the documentation, please report them to us in writing. Miranda does not warrant that 
this document is error-free.

FCC Statement 
This equipment has been tested and found to comply with the limits for a Class A digital device, 
pursuant to part 15 of the FCC Rules. These limits are designed to provide reasonable protection 
against harmful interference when the equipment is operated in a commercial environment. This 
equipment generates, uses, and can radiate radio frequency energy and, if not installed and used in 
accordance with the instruction manual, may cause harmful interference to radio communications. 
Operation of this equipment in a residential area is likely to cause harmful interference in which 
case the user will be required to correct the interference at his own expense.

Declaration of Conformance (CE) 
All of the equipment described in this manual has been designed to conform with the required 
safety and emissions standards of the European Community. Products tested and verified to meet 
these standards are marked as required by law with the CE mark. (See Symbols and Their Mean-
ings on page v.)
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When shipped into member countries of the European Community, this equipment is accompanied 
by authentic copies of original Declarations of Conformance on file in Miranda GVD offices in 
Grass Valley, California USA.

Trademarks
Miranda is a registered trademark of Miranda Technologies, Inc.

Brand and product names mentioned in this manual may be trademarks, registered trademarks or 
copyrights of their respective holders. All brand and product names mentioned in this manual serve 
as comments or examples and are not to be understood as advertising for the products or their man-
ufactures.

Software License Agreement and Warranty Information
Contact Miranda for details on the software license agreement and product warranty.

Technical Support Contact Information 
Miranda has made every effort to ensure that the equipment you receive is in perfect working order 
and that the equipment fits your needs. In the event that problems arise that you cannot resolve, or 
if there are any questions regarding this equipment or information about other products manufac-
tured by Miranda, please contact your local representative or contact Miranda directly through one 
of the appropriate means listed here.

• Main telephone: 530-265-1000 (9 am to 9 pm PST)
Fax: 530-265-1021 

In the Americas, call toll-free: +1-800-224-7882 (9 am to 9 pm EST)
In Europe, the Middle East, African or the UK, call  +44 (0) 1491 820222 (9 am to 6 pm, GMT)
In France, call +33 1 55 86 87 88 (9 am to 5 pm, GMT + 1)
In Asia, call +852-2539-6987 (9 am to 5 pm, GMT + 8)
In China, call +86-10-5873-1814

• Emergency after hours: toll-free: +1-800-224-7882
Tel: +1-514-333-1772 

• E-Mail: 

In the Americas, support@miranda.com
In Europe, the Middle East, African or the UK, eurotech@miranda.com
In France, eurotech@miranda.com
In Asia, asiatech@miranda.com
In China, asiatech@miranda.com

• Website: http://www.miranda.com

• Mail Shipping

Miranda GVD Miranda GVD
P.O. Box 1658 125 Crown Point Court
Nevada City, CA 95959, USA Grass Valley, CA 95945, USA 

Note Return Material Authorization (RMA) required for all returns.
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Change History
The table below lists the changes to the Master Control MasterLogo User’s Guide.

• MasterLogo User’s Guide Part # UG0010-08

• Software version: 6.3.6.0 

Re v Date ECO De scription Approved By

1.0 15 Aug 05 — Original document —

2.0 27 Sep 07 — Revised format, added new features. D. Cox
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3.1 26 Jun 08 14766 Minor changes. D. Cox

3.2 14 Jan 09 15478 Number of logos allowed increased to 400 for MCEs. D. Cox
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D. Cox

3.4 31 Aug 09 16036 Conforms to software revision 6.2.0, but no functional 
change.

D. Cox

3.5 11 Jan 10 16257 Conforms to software revision 6.3.1 (extended logo 
length for MCEs, etc.).

D. Cox
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important changes to this guide.)

D. Cox

3.7 17 Feb 11 17447 Conforms to software revision 6.3.6. (There are no 
important changes to this guide.)

D. Cox
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Important Safeguards and Notices
This section provides important safety guidelines for operators and service personnel. Specific 
warnings and cautions appear throughout the manual where they apply. Please read and follow this 
important information, especially those instructions related to the risk of electric shock or injury to 
persons. 

Symbols and Their Meanings

The lightning flash with arrowhead symbol within an equilateral triangle alerts the user to the pres-
ence of dangerous voltages within the product’s enclosure that may be of sufficient magnitude to 
constitute a risk of electric shock to persons.

The exclamation point within an equilateral triangle alerts the user to the presence of important 
operating and maintenance/service instructions.

The Ground symbol represents a protective grounding terminal. Such a terminal must be connected 
to earth ground prior to making any other connections to the equipment.

The fuse symbol indicates that the fuse referenced in the text must be replaced with one having the 
ratings indicated.

The presence of this symbol in or on Miranda equipment means that it has been designed, tested 
and certified as complying with applicable Underwriter’s Laboratory (USA) regulations and rec-
ommendations.

The presence of this symbol in or on Miranda equipment means that it has been designed, tested 
and certified as essentially complying with all applicable European Union (CE) regulations and 
recommendations.

Warning Any instructions in this manual that require opening the equipment cover or 
enclosure are for use by qualified service personnel only. To reduce the risk of 
electric shock, do not perform any service other than that contained in the operat-
ing instructions unless you are qualified to do so.
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General Warnings

A warning indicates a possible hazard to personnel which may cause injury or death. Observe the 
following general warnings when using or working on this equipment:

• Heed all warnings on the unit and in the operating instructions.

• Do not use this equipment in or near water.

• This equipment is grounded through the grounding conductor of the power cord. To avoid elec-
trical shock, plug the power cord into a properly wired receptacle before connecting the equip-
ment inputs or outputs.

• Route power cords and other cables so they are not likely to be damaged.

• Disconnect power before cleaning the equipment. Do not use liquid or aerosol cleaners; use 
only a damp cloth.

• Dangerous voltages may exist at several points in this equipment. To avoid injury, do not touch 
exposed connections and components while power is on.

• Do not wear rings or wristwatches when troubleshooting high current circuits such as the power 
supplies.

• To avoid fire hazard, use only the specified fuse(s) with the correct type number, voltage and 
current ratings as referenced in the appropriate locations in the service instructions or on the 
equipment. Always refer fuse replacements to qualified service personnel.

• To avoid explosion, do not operate this equipment in an explosive atmosphere.

• Have qualified service personnel perform safety checks after any service.

General Cautions

A caution indicates a possible hazard to equipment that could result in equipment damage. Observe 
the following cautions when operating or working on this equipment:

• When installing this equipment, do not attach the power cord to building surfaces.

• To prevent damage to equipment when replacing fuses, locate and correct the problem that 
caused the fuse to blow before re-applying power.

• Use only the specified replacement parts.

• Follow static precautions at all times when handling this equipment.

• This product should only be powered as described in the manual. To prevent equipment dam-
age, select the proper line voltage on the power supply(ies) as described in the installation doc-
umentation.

• To prevent damage to the equipment, read the instructions in the equipment manual for proper 
input voltage range selection.

• Some products include a backup battery. There is a risk of explosion if the battery is replaced by 
a battery of an incorrect type. Dispose of batteries according to instructions.

• Products that have (1) no on/off switch and (2) use an external power supply must be installed 
in proximity to a main power output that is easily accessible.
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1. MasterLogo 

This chapter describes MasterLogo, an application that adapts graphic images and animations for 
use with the NV5100MC Master Control System. It presents the following sections: 

• Summary • Managing Logo Images 
• Installation • Working with MasterLogo 
• Starting MasterLogo • Other Topics 

Summary 
MasterLogo is a small program that converts your logo artwork to the format required by the logo 
inserters integral to the MCPM. MasterLogo also sends logos to the MCPM. (MasterConfig 
invokes MasterLogo when you write a configuration to an MCPM.)

MasterLogo supports MCEs, which are MCPMs having new architecture. MCEs provide additional 
support for logos. 

In practice, logos are used to identify a television station during programming and have now 
become an integral part of a station’s overall branding regimen. Logos are often animated and used 
to advertise upcoming programs or events, identify sponsors, or to provide information about the 
current program.

A logo can be any graphic image, of course; it need not be a “company logo” per se.

MasterLogo has two functions: (1) convert graphics to logo format and (2) create lists of logo files 
that are to be loaded with MCPM configurations.

MCPMs and MCEs support animated or stationary logos. Animated logos may run once or loop, 
and if they loop, they may pause at the end of the loop.

MCPMs
MCPMs have up to 128 MB or up to 512 MB of RAM in which to store logos, depending on the 
model. HD logos require the larger memory. The maximum number of logos of any type is 64.

The first logo (identified in the MasterConfig logo images list by selno 1) is stored in non-vola-
tile memory (flash) and is always available immediately after an MCPM restarts. It must be 
static, and must be less than 1.7MB in size. The MCPM stores all other logos in logo RAM 
(volatile) and you must upload these logos to the MCPM prior to use. The upload process is 
semi-automatic. You will be prompted to upload them after a reset initiated by MasterConfig. 
You must upload logos manually after a power cycle. The maximum file size for these logo 
images is 2.3MB per image.

The maximum number of frames for an animated logo image is 256. At 30 fps, that amounts to 
8.5 seconds of animation. At 25 fps, that is 10.2 seconds of animation. 
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MCEs
MCEs have up to 2GB of memory in which to store logos. The maximum number of logos of any 
type is presently 400. The maximum number of frames for an animated logo image is 900. 

All logos in an MCE reside in non-volatile storage. It is not necessary to reload logos at every 
restart. 

Logo Basics
A logo is a graphic element stored in the MCPM. A logo comprises one or more files to be keyed 
into the program video signal. There are two principle types of logos:

• A basic (or static) logo. This logo type uses one image file (the fill) and, usually, one mask file 
(the key). After MasterLogo processes a static logo, it combines the key and fill in a single file. 
The mask (key) is a pixel matrix of the same dimension as the image (fill) file. When the fill 
and key are combined, black pixels in the mask completely hide the logo pixel on the video mix 
and white pixels completely reveal the logo pixel in the video mix. Gray values in the key allow 
partially opaque (or partially transparent) logo pixels.

• An animated logo. The source for this logo type is a set of files whose names include sequence 
numbers at the end of the name:
motion01.tga, motion02.tga, motion03.tga, motion04.tga, ...

Each of these files corresponds to one video frame. If the frame rate is 30 fps, and the animation 
has 60 files, the animation lasts 2 seconds.

Preferred source files for animations are Targa flip-book format files. (Acceptable Targa 
files are 24-bit RGB + 8-bit alpha. The alpha channel is the logo key.) Other file types are 
acceptable but do not generally have an alpha channel and result in a self-keying animation.

Preparation of graphics for logos
Your graphics department will typically prepare logo images and provide them electronically, in a 
common file format, to be converted by MasterLogo and managed by MasterConfig users. Master-
Logo converts that file format into the internal format required by the MCPM. 

MasterLogo converts the following file formats: 

Format Name Description
TIF Tagged Image 

File
Images in this format work quite well and provide very good quality. 

BMP Bitmap A bitmap can provide a high quality logo. However, some BMP files have 
reduced color sets.

JPEG,
JPG

Joint Picture 
Experts Group

A compressed file format. Because JPEG format suppresses fine detail, and 
introduces artifacts, it might not be the best choice. Some JPEG files can be 
very noisy. Repeatedly saving JPEG files can result in image degradation.

PNG Portable 
Network Graphic

Images in this format work quite well. 

TGA Targa This is a preferred format. The Targa file includes key or alpha channel 
information so a separate key file is not needed.  

GIF Graphics 
Interchange 
Format

GIF files are indexed color files and often used for Internet graphics. They are 
usually not suitable for photos or continuous tone images.
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Logo graphics for use with the NV5100MC should meet the following basic requirements:
• A graphic file contains the logo image actual size. MasterLogo does not resize graphics. It is 

important that the image never exceed the dimension of your video format.
• For all but one of the graphic file types, a logo will require separate files for the logo fill and the 

logo key. Targa flip-book files and Targa individual files provide both fills and keys that Mas-
terLogo recognizes; therefore, separate files are not required.

Although “full screen” logos are possible and occasionally useful, small logos that can be posi-
tioned in MasterConfig (and repositioned by the operator) are more efficient and occupy less 
memory. When logos are small, you can fit more logos in an MCPM’s logo memory.

The quality of the resultant logo image will depend heavily upon the original artwork and specifi-
cally the key signal (or alpha channel) — just as it would with any other keyer source. For other 
than Targa files, you should provide a separate file for the key signal whenever possible. 

It is possible to have MasterLogo create a key signal based on luminance values from the fill, but as 
with any “luma key,” results will probably be sub-optimal, especially concerning transparency or 
shadow.

Installation 
MasterLogo is part of the software available on the installation disk ( SB0221) you received with 
your NV5100MC system. 
Follow the simple installation procedure outlined in the Master Control Quickstart Guide or the 
Master Control Installation Guide. 

User accounts for PCs used for master control must be set to ‘Standard User’ or better. Master con-
trol software does not function properly when user accounts are set to ‘Restricted User’ or its 
equivalent.

Starting MasterLogo 
Although MasterLogo is very simple, you should be familiar with the concepts presented in the pre-
ceding Summary before using MasterLogo. 

There are 3 ways to launch MasterLogo:
• Use the Windows Start menu.
Programs > NVISION > Master Control > MasterLogo - Convert and Load Logos into MCPM

• Double-click the actual program file. This is the default:
C:\Program Files\NVISION\Master Control\bin\MasterLogo.exe

• Double-click a shortcut (that you have created) to the actual program file.
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Managing Logo Images 
There are 4 steps to creating and using a logo successfully. The first two steps use MasterConfig. 
The last two steps use MasterLogo.

Theory
An MCPM configuration has a numbered list of up to 64 logo image names. An MCE configura-
tion has a numbered list of up to 400 logo image names. Each entry in the list also specifies whether 
the logo is to be a static or an animated logo. Each of the configuration’s logo names can be used by 
any of up to 64 (MCPM) or 400 (MCE) logo keyers. The keyers define parameters such as logo 
opacity and position within the video frame. The same logo image can be used by different logo 
keyers with different parameters.

As a MasterLogo user, you will create one or more logo files, either static or animated. Each static 
logo is a single file; each animation is a set of files, one for each animation frame. 

MasterLogo creates an association between a logo file (static or animated) and one of the MCPM’s 
logo names. MasterLogo stores up to 64 such associations in a .XML file (for each MCPM) within 
Master Control’s ‘config\system’ folder.

When you write a configuration to an MCPM or MCE — using MasterConfig  — MasterConfig 
invokes MasterLogo to upload the logo files. MasterLogo reads the .XML file for the specific 
MCPM or MCE to determine which logos to upload. 

You can view all current file-to-logo-name associations  — in detail — by issuing a “Write to 
MCPM> All  Logos” command in MasterLogo. 

To associate a logo file with a logo image name requires that you have an MCPM installed, run-
ning, and selected in MasterLogo. 

The targeted MCPM must have enough logo memory for you to upload the logo. 

The process creates an MCPM configuration with logos. The resulting configuration can be 
applied to other MCPMs (of the same type), and not just the MCPM to which you originally 
sent logos from MasterLogo.

MCEs are different from other MCPMs.

MCPMs

The first logo (selno 1, in MasterConfig) is always written to flash. Other logos are written to 
RAM. The first logo is non-volatile and need not be loaded after every MCPM reset.

It is prudent to assign your most important logo as the first logo.

MCPM logo memory is either 128 MB or 512  MB. MCPMs allow up to 64 logo images and 64 logo 
keyer definitions.

MCEs

All logos are written to non-volatile memory. MCE memory is 2 GB. MCEs allow up to 400 logo 
images and 400 logo keyer definitions
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Process
Follow these steps to create and use a logo:

1 Determine the name you want to use for the logo. Enter the name into the Logo Images list in 
MasterConfig. MasterConfig allows up to 64 images in this list: 

2 Next, define logo attributes such as position, behavior, and opacity using the Logo Keyer 
Sources window in MasterConfig: 

Save the configuration and write it to the MCPM you will use in MasterLogo.
(See the NV5100MC Master Control Reference Manual for details regarding logo parameters.)

3 In MasterLogo, create the logo (static or animated) by opening a graphics file. Saving the file as 
a logo converts the logo to the format required by an MCPM. 
See Working with MasterLogo, next.

4 Using MasterLogo, upload the logo into MCPM memory. 
It is this last step that associates the logo name in MasterConfig with the logo file. You must 
perform this step only once. Thereafter, both MasterLogo and MasterConfig can automatically 
upload your logo(s) to the MCPM. You can change the association later, if you wish.
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After the logo is in MCPM memory, you might wish to view and adjust its behavior on a 
preview monitor. You can then make adjustments to its default position and opacity values 
in MasterConfig. 

Repeat these steps for other logos. 

Working with MasterLogo
Before using MasterLogo, you must prepare your graphic input files.
Decide whether to use a static logo or animated logo.
Consider factors such as the position and size of the logo within your target video output and the 
opacity (or transparency) of the logo. Note that an MCPM configuration might allow an master 
control operator to adjust logo opacity and position.

Preliminary Steps for Static Logos
Create or obtain a graphic image file in one of the recognized formats. Decide whether to use a sep-
arate key file. 

A separate key file is recommended, except for Targa files. MasterLogo assumes that your 
Targa file has 24-bit RGB color and an 8-bit alpha channel. (A Targa file generated from Photo-
shop, for example, might not.) 

If you use a separate key file, it must reside in the same folder as the image (fill) file and its name 
must be the same as the image file’s name but with “key” added at the end of the name. For exam-
ple, if your logo fill file is “logoNV.tif,” the matching key file should be named “logoNVkey.tif.” 

If you do not use a separate key file, then you must use the luminance from the fill file to create the 
key. (In MasterLogo, choose ‘Tools > Use Luminance...’.) When you choose this option, Master-
Logo does not look for a key file, and will ignore the key if it is present. 

Preliminary Steps for Animated Logos
Decide the how long the animation is to be. The MCPM displays one animation file for each video 
frame. The length of your animation is a function of the number of files you create and the frame 
rate of the target video output. At 30 fps, a 2-second animation requires 60 Targa files.

Prior to software revision 6.3.1, animations were limited to 256 frames. At software revision 
6.3.1, an MCE’s animations may be up to 900 frames. Animations in other MCPMs are still 
limited to 256 frames.
For MCPMs other than MCEs, the first logo in the Logo Images list in MasterConfig must not 
be an animation because it is to reside (by itself) in flash memory. 

Decide whether the animation will loop and, if it does, how much of a delay you want before the 
animation repeats.

Create or obtain a set of animation files. The preferred type for animations is Targa format. Master-
Logo assumes that your Targa files have 24-bit color and 8-bit alpha channels. The animation files 
must all be in the same folder, and have identical names except that the files must be sequentially 
numbered, the number coming at the end of the file name:
anim01.tga, anim02.tga, anim03.tga, anim04.tga, ...
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Gaps must not exist in the sequence. If a gap occurs, MasterLogo assumes that it terminates the 
sequence.

Creating a Static Logo
Follow these steps to create a logo:

1 Launch MasterLogo. 

2 In the ‘Tools’ menu, ensure that the setting of the luminance key toggle matches the logo file(s) 
you want to open: 

Check “Use Luminance...” item if you have no key file. Leave the option unchecked for Targa 
files.

3 Select File > New> Basic Logo to open a static file. 
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A “Select image (fill) to use” dialog appears:

Browse to the location of the logo image file(s). Select the fill file and click ‘Open’. If the logo 
requires a key file, MasterLogo looks for it. If it does not find a key file, it issues a warning and 
tells you it will use luminance from the fill file as the key.

4 After a moment, a “Save logoimage as” dialog opens: 

Enter the name for the processed logo file. Its extension must be .mrlogo.

We recommend saving .mrlogo files in the default location: 
C:\Program Files\NVISION\Master Control\config\logo\mrlogo\
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5 A confirmation alert appears: 

Click ‘OK’ to proceed.

6 Finally, an ‘Info’ message displays the details of the static logo created: 

Click ‘OK’. The logo is ready to upload.

Creating an Animated Logo
Follow these steps to create a logo:

1 Launch MasterLogo. 
2 In the ‘Tools’ menu, ensure that the luminance key toggle is off (unchecked): 

3 Select File > New> Animated Logo to open an animated logo. 
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A “Select image to use for first frame of animation” dialog appears: 

Browse to the location of the animation file(s). Select the file whose name ends in “01” and 
click ‘Open’. 
MasterLogo then displays this dialog asking you to the name the animation: 

The suggested name is the base name of the animation file set. MasterLogo creates a folder of 
the name you specify. MasterLogo will then ask you whether you really want to create the ani-
mation files: 

Click ‘Yes’ to create the files.
The names of the files in the folder are the same as the folder’s name with numbers at the end. 
The extension for the file names is .mrlogo.

If you do not select the first file in the animation sequence, the result will be a shorter 
sequence. For example, if you clicked the third file (out of 30 files), MasterLogo will create 
an animation of 28 files. The file numbered 01 matches your number 03 Targa file and file 
number 28 matches your number 30 Targa file.)
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If MasterLogo finds a gap in the sequence, it stops at the file with the highest number before 
the gap. For example, if the ‘05’ file is missing from a sequence of 01–60, MasterLogo cre-
ates an animation of the first 4 files only.

4 Processing time depends on PC performance and animation length and complexity. You will see 
a progress display: 

Click ‘Cancel’ to terminate the operation before it completes.
5 At completion, the progress panel disappears and a confirmation appears: 

The animation is ready for you to upload to the selected MCPM.

Uploading Logos to the MCPM
You can upload either a single logo (animated or static) or all logos. “All logos” means all the logos 
you have associated with logo names in the target MCPM.

Keep in mind the following points:
• A maximum of 64 logo files may be loaded into the MCPM memory, subject to the limits of 

logo memory. 
• Logo file storage.

For MCPM that are not MCEs, the first logo image is stored in non-volatile flash memory; all 
other logo files are stored in RAM and will be lost when the MCPM restarts. The first logo 
image is defined as the first entry in MasterConfig’s Logo Images table. All other logo images 
must be uploaded to the MCPM every time power is lost or the MCPM is reset. (The first logo 
must not be an animation.)

Single Logo

To write one logo to the MCPM follow these steps:
1 Make sure that MasterConfig has an entry and settings for the logo you want to transfer. The 

configuration that includes the logo must have been loaded in the target MCPM.
2 Launch MasterLogo.
3 Set (or choose) the IP address of the MCPM to which you want to add the logo.
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There are several ways to select an MCPM. See Selecting MCPMs and MCEs on page 24.
4 Select File > Write to MCPM> Logo.... 

If you have not designated an IP address (to select an MCPM), MasterLogo prompts you for 
one. Enter the target MCPM’s IP address and click OK.

Be sure you are not writing a logo to the wrong MCPM!

5 After a moment, a list of logo image names appears: 

(MasterLogo reads in the list of basic logo images from the target MCPM. Animations are not 
included in this list.)
Choose the logo image name with which you wish to associate your logo file.
MasterLogo displays the pathname of the logo file that it will send. If you wish to select another 
logo file, click ‘Browse’ to display a window in which to select another file. (Valid logo files 
have the extension mrlogo.) Click ‘Open’ when you have chosen a file.
Finally, click ‘OK’ in the ‘Send logo’ window. MasterLogo sends the logo across the master 
control network to the MCPM. 

It is this step that associates the logo image name in the MCPM’s configuration with the 
logo file. You must perform this step only once. Thereafter, both MasterLogo and Master-
Config can automatically upload your logo(s) to the MCPM. You can change the associa-
tion at any time. 

All Logos

Writing logos to an MCE is different from writing logos to other MCPMs. (All logo storage in 
MCEs is non-volatile.)
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MCPMs

To write all logos to an MCPM, follow these steps:
1 Make sure that MasterConfig has entries and settings for the logos you want to transfer.
2 Launch MasterLogo.
3 Set (or choose) the IP address of the MCPM to which you want to add the logo.

There are several ways to select an MCPM. See Selecting MCPMs and MCEs on page 24.
4 Select File > Write to MCPM> All Logos.... 

If you have not designated an IP address (to select an MCPM), MasterLogo prompts you for 
one. Enter the target MCPM’s IP address and click OK.

Be sure you are not writing the logos to the wrong MCPM!
5 The “Send these logos” dialog appears: 

Figure 1 -1. Left Side of the Display

This is an information display only. The one option you have is whether to write logo 1 to non-
volatile memory (flash) or to skip writing it. In this example, Master Control will send 3 logos, 
two of which are animations. It will not send logo 1. 
(Logo 1 always resides in flash within the MCPM and will remain there forever unless you 
want to change it. It is not necessary to load logo 1 every time you load all logos. It also take a 
extra time to load it because flash updates more slowly than RAM.)
Click ‘OK’ if you want to send these logos. Click ‘Cancel’ if you do not. 
The display has many (adjustable) columns. The columns on the left include:

Logo Image Number The logo selection numbers as defined in MasterConfig.
Logo Image Name The logo names as given in MasterConfig.
Logo File The base name of the logo file. The base name of an animation is pre-

sented without any sequence number.
Logo Type Either “Basic” or “Animation.”
Width, Height The size of the logo, in pixels.
Frames The number of frames in the logo. Static logos have only one frame.
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Finally, when you click ‘OK’, MasterLogo displays a progress panel: 

Click ‘Cancel’ if you want to terminate the transfer before it completes.
6 After some time passes (it might be several minutes, depending on the number and complexity 

of the logos), the logos will have been transferred across the network and the progress panel 
disappears. 

MCEs

To write all logos to an MCE, follow these steps:
1 Make sure that MasterConfig has entries and settings for the logos you want to transfer.
2 Launch MasterLogo.
3 Set (or choose) the IP address of the MCE to which you want to add the logo.

There are several ways to select an MCE. See Selecting MCPMs and MCEs on page 24.
4 Select File > Write to MCPM> All Logos.... 

If you have not designated an IP address (to select an MCE), MasterLogo prompts you for one. 
Enter the target MCE’s IP address and click OK.

Be sure you are not writing the logos to the wrong MCE!

Logo Keyer Source(s) The keyer settings that use the particular logo. There could be more 
than one.

Complete logo file 
name and path

The pathname of the logo image. Pathnames are contained in the 
.XML file for this MCE’s logos. 
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Because writing logos to an MCE takes a long time and it is usually not necessary, MasterLogo 
displays this message:

Click ‘OK’ if you really want to write all logos or click ‘Cancel’ if you do not.
5 If you clicked ‘OK’ in step 4, the “Send these logos” dialog appears: 

Figure 1 -2. Left Side of the Display

This is an information display only. Click ‘OK’ if you want to send these logos. Click ‘Cancel’ 
if you do not. 
The display has many (adjustable) columns. The columns on the left include:

Logo Image Number The logo selection numbers as defined in MasterConfig.
Logo Image Name The logo names as given in MasterConfig.
Logo File The base name of the logo file. The base name of an animation is pre-

sented without any sequence number.
Logo Type Either “Basic” or “Animation.”
Width, Height The size of the logo, in pixels.
Frames The number of frames in the logo. Static logos have only one frame.
Logo Keyer Source(s) The keyer settings that use the particular logo. There could be more 

than one.
Complete logo file 
name and path

The pathname of the logo image. Pathnames are contained in the 
.XML file for this MCE’s logos. 
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Finally, when you click ‘OK’, MasterLogo displays a progress panel: 

Click ‘Cancel’ if you want to terminate the transfer before it completes.

6 After some time passes (it might be several minutes, depending on the number and complexity 
of the logos), the logos will have been transferred across the master control network and the 
progress panel disappears. A confirmation panel appears:

Click ‘OK’ to dismiss it.

Other Topics

File Menu 

Choose ‘New’ to create a new logo from a graphics file. You can create a basic (static) logo or an 
animation. 
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Choose ‘Write to MCPM’ to upload a logo to the MCPM. You can upload a single logo or all logos. 
See Uploading Logos to the MCPM on page 11 for information.

Click ‘Exit’ to close and leave MasterLogo.

Communication Menu 

Choose ‘Ethernet to MCPM...’ to specify the IP address of the MCPM with which you want to 
work. MasterLogo displays the following dialog in which to enter the IP address: 

By checking ‘Log Comm Messages’, you can create a log file of messages between the MCPM and 
your PC. When you check the option, MasterLogo displays a browser dialog in which you can 
choose the folder and file in which to keep the log.

View Menu 

Click ‘Master Control Tree’ to display the MCPM list. (The list mimics the appearance of a Win-
dows directory tree, with expandable and collapsible entries.) The command is not a toggle. To 
close the tree area, click the small X in its upper right corner. You can resize the tree area by drag-
ging its right-hand border to the right or left.

You might have to populate the MCPM list, at least initially. See Selecting MCPMs and MCEs on 
page 24.

Tools Menu 

Check ‘Use Luminance for key if no separate key file’ when there is no separate key file for the 
logo. Leave the option unchecked otherwise.

Help Menu 
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The ‘Help’ menu does not actually provide help, but it identifies the product revision: 

and tells you how to reach Miranda technical support: 

Notes
The current revision of MasterLogo revision is 6.3.3.0.

Adobe Photoshop is an excellent image processing tool, especially for creating masks (or keys). It 
can save files in many formats, including PNG, JPEG, TGA, BMP, TIF, and GIF formats. Not all its 
formats or variations of formats are necessarily acceptable or useful to MasterLogo. If you are 
using Photoshop, verify that its output can be used by MasterLogo. 
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Photoshop can save 16-bit, 24-bit, and 32-bit Targa files. You want 24-bit color with an 8-bit alpha 
channel.

There are many variations of GIF format.

Tip

Here is a straightforward way to generate a mask (or key) in Photoshop. 
1 Create or acquire artwork (layered or not). A transparent background works best.
2 Select the art using any of the Photoshop tools and techniques you prefer. Your selection will 

become the mask. The selection or portions of it can be feathered.
It is not always easy to make a good selection. It is not always easy to predict the effect a 
mask will have on the resulting video. You can try again or you can edit the mask after-
wards.

3 Having a selection, click the “quick mask mode” icon in the toolbar. Your selection will turn 
color (typically reddish) and the “marching ants” selection lines disappear. 

4 Go to the channels palette (switching away from the layers palette). Clear all channels except 
the Quick Mask channel. Select all.

5 Switch back to the layers palette. Be sure quick mask mode is off. Now paste your selection 
from the Quick Mask channel. It should become a new layer.

6 The new layer can be used as a mask. Post-process the mask as you require. Remember that, to 
MasterLogo, white selects and black masks (and grays are proportionally in between). You 
might need to invert your mask.

Troubleshooting 
The following is a list of common problems with logos: 

Problem Possible Solution

MasterLogo does not rec-
ognize a key file.

Luminance key mode enabled. Uncheck ‘Use Luminance’ in the Tools 
menu. 
Rename the “key” file according to convention. If the fill file name is 
“ABC,” then the key file must be named “ABCkey.”

After writing logos to the 
MCPM, they are not visi-
ble when placed on-air.

Required configuration settings are missing. Review the settings in 
MasterConfig’s ‘Logo Images’ and ‘Logo Key Sources’ pages.

Keyed logo does not 
appear as expected.

Check the type and structure of your original graphic file(s). Be sure 
that the luminance key mode is set properly. 

Examine the gain, clip, and opacity settings in MasterConfig’s ‘Logo 
Key Sources’ page.
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2. Misc. 

Chapter 2 provides miscellaneous information about MasterLogo. It presents the following topics:
• Installation 
• PC Configuration 
• Selecting MCPMs and MCEs 

Installation 
The assumption in this guide is that your software was already installed. If you need to install the 
software, the process is simple:

1 Obtain the master control software installation CD. (Use either SB0075-xx for older 
NV5100MC systems or SB0221-xx for “next generation” systems incorporating MCEs). Insert 
the disk in your CD drive. After a few seconds, the auto-run application will launch. Use its 
buttons to select and operate the installer. 
(You may also browse the CD directory and double-click InstallConfig.msi, which will then 
start and wait for your input.) 

2 When the installer is running, follow the instructions given, clicking ‘Next’ as you proceed to 
move from step to step. The entire installation process takes less than a minute.
If you have any existing Miranda master control software, you must remove it before you can 
install new master control software. 

3 Create a desktop shortcut (if you wish) for MasterLogo. Its default pathname is
C:\Program Files\NVision\Master Control\bin\MasterLogo.exe
The default path in the Windows Start menu is: 
Programs > NVision > Master Control > MasterLogo - Convert and Load Logos into MCPM

Documentation, including this manual, is available on either CD.

To launch MasterLogo, (1) choose the application from the Windows Start menu, (2) double-click 
the application in its folder, or (3) double-click its desktop shortcut.

Reinstallation may overwrite some of your configuration files — the ones installed as defaults 
in the Master Control folder, such as MasterPanel.uicfg or SCP.uicfg. To be safe, save a copy of 
your old configuration files before installing new Master Control software.

Configuration files stored outside the Master Control folder are never affected. 

MasterLogo is not affected. 

If you delete the old Master Control folder before reinstalling new software, you might inad-
vertently lose certain important files. In particular, you could lose the .XML files that support 
MasterLogo and MasterConfig. 
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PC Configuration 
You (or your system administrator) must connect the PC on which your software runs to the master 
control network. To do that, you must assign the PC an IP address (and mask) on the NIC that con-
nects the PC to the master control network. (The PC must also be connected to the Ethernet switch 
of the network.) 

Follow these steps to set the IP address of your PC:

1 Launch ‘Settings > Network Configuration’ from you PC’s Start menu. The following window 
appears: 

2 Double-click the appropriate ‘Local Area Connection’ for your master control network. Then, 
choose the General tab and click ‘Properties’. 
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3 Select Internet Protocol (TCP/IP). Click ‘Properties’ again here:

4 Select ‘Use the following IP address’ and enter an IP address for your PC. Use the default sub-
net mask.

The IP address must be unique on the network. (The subnet mask must be 255.255.255.0.)

5 Click OK and it is done. Close all the Network Connections windows. 
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Selecting MCPMs and MCEs 
To upload logos to an MCPM, you must select the MCPM. There are two ways:

• Through the IP address dialog.
• In the MCPM “tree” area.

(MCEs are MCPMs with new architecture and are included in the MCPM “tree.”) 

IP Address Dialog

Choose ‘Ethernet to MCPM...’ from the ‘Communication’ menu to display a dialog in which to 
enter an IP address. 

Consult your system administrator if you need to obtain the IP addresses for MCPMs in your sys-
tem.

MCPM Tree Area

Choose ‘Master Control Tree’ from the ‘View’ menu to display the MCPM list, if it is not already 
displayed. To select an MPCM, simply click the list entry for the MCPM in the MCPM list.

The first time you use MCPM list, it will probably be empty. To add an MCPM to the list, right-
click the word MCPM at the top of the tree area and then click the ‘Add MCPM’ button: 

The MCPM Configuration dialog appears. 

Enter the IP address and optionally a name for the MCPM. 

You can create list entries for MCPMs that do not (yet) exist, although you cannot write to non-
existent MCPMs. 

Consult your system administrator if you need to obtain the IP addresses for MCPMs in your sys-
tem.
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You can change any MCPM in the list by right-clicking it and choosing an option:

You may re-enter the MCPM’s IP address and name or delete the MCPM from the list. 

Click ‘Write Config to MCPM...’ to upload configuration data from a file to the MCPM. 

The configuration is one created in MasterConfig. A configuration is often, but not always 
associated with the MCPM list entry in MasterLogo’s tree area.

XML Files

The MCPM list in the tree area is supported by an XML file in the Master Control program folder.

Both MasterLogo and MasterConfig share the XML file. After the list has been populated in Mas-
terConfig, it will appear automatically in MasterLogo’s tree area. The reverse is true. After the list 
has been populated in MasterLogo, it will appear automatically in MasterConfig’s tree area. 

Occasionally the MCPM list will have been created on someone else’s computer. If the list is large, 
it might be worth your while to obtain the XML file from the other PC. If you copy the list to your 
program folder, MasterLogo and MasterConfig will automatically display the MCPM list.

The default pathname of the XML file on any PC is: 
C:\Program Files\NVision\Master Control\config\system\mcpm.xml

The location of your software might be different. In any case, the subfolder config\system is 
where to find the XML file and where it must reside for proper operation.

Ensure that there is an mcpm.xsd file in that same folder. If you have no such XSD file, you might 
have to reinstall the master control software.

You will probably find other XML (and XSD) files in that folder. Do not remove these files 
unless you are sure of what you are doing.
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